Feature Highlights

KeyShot 7 is our biggest update yet with new features an enhancements that cover every area of KeyShot. Below you'll find the top features in this release with short description on how it works and a link to more information. 

Workspaces

Workspaces allow you to select preset UI arrangements or save your own custom arrangements of the KeyShot UI to best suit the way you work. Workspaces remember window dock state, position and size, Library and Project tab order, tab visibility, torn-off tab state, Toolbar and Ribbon position and Ribbon icon visibility. Learn more in the manual on the Workspace page.

How it Works
The Ribbon at the top of the KeyShot UI now contains a dropdown menu at the far left where you can select, add, and manage Workspaces. To create your own custom Workspace make adjustments to any of the items mentioned above click the Workspaces dropdown and select Add… to launch a name entry field and save. To save changes to an existing Workspace click Apply Changes… To adjust display order, import, export, or delete Workspaces click Manage...

Custom Hotkeys

KeyShot 7 now allows you to assign custom hotkeys for many KeyShot commands. Learn more in the manual about the new Hotkeys

How it Works
The Hotkeys preferences can be accessed by selecting Edit, Preferences and selecting the Hotkeys section or by pressing the K-key to show the Hotkeys Overview where you will see a button for Setup/Details... in the bottom right corner. This will take you to the Hotkeys section of the Preferences page. Here you can set custom Hotkeys for any of the listed actions.

New Material Types

The Plastic (Cloudy) material type contains light-scattering particles to replicate complex, scientifically accurate materials such as Polycarbonate or ABS. This material has settings to control light Transmission, Cloudiness, and Scattering Directionality. Read more about Plastic (Cloudy) material type here.

The Measured material type allows you to load measured material files in .axf or .xml format. Read more about measured materials here.

How it Works
When editing an existing material select Plastic (Cloudy) or Measured from the Material Type drop-down.

Material Enhancements

Dielectric-based material types - Glass (Solid), Liquid, Dielectric, Gem - have been updated with a unit-aware Transparency Distance setting that allows you to specify the distance through the material at which the defined color is achieved. Learn more about the Glass (Solid), Liquid, Dielectric and Gem material types.

The Metal material type now includes options for Color and 13 scientifically accurate metal presets including Aluminum, Brass, Chromium, Copper, Gold, Iron Magnesium, Nickel, Niobium, Platinum, Silver, Titanium, and Zinc. These, along with the ability to load Complex IOR files (.ior, .nk, .csv), may be chosen for custom metal appearances. All metal preset provide the additional ability to add an anodized coating with control of Film Refractive Index, Film Extinction Coefficient, and Film Thickness. The Anodized settings are available for all metal presets selected from the Metal Type drop-down. Learn more in the manual on the Metal material type page.

The Metallic Paint material type now has settings for Clear-coat Color, which allows you to create deep rich candy coats and can be further controlled by a Clear-coat Thickness. In addition, the new Clear-coat settings may have a textured applied, which does not affect the Base coat. Learn more in the manual on the Metallic Paint material type page.

Translucent and Translucent (Advanced) material types have been updated with a unit-aware Translucency setting, which defined the distance light is able to penetrate the material. Learn more about the Translucent and Translucent (Advanced) material types.

The Toon material type now has control of Shadow Color and the ability to control the visibility of shadows produced by Light Source Materials. The Shadow Color setting can be textured to achieve sketch-like shading effects and much more. Learn more about the Toon material type.

The Ground material type now has control of Reflection Contrast in order to easily increase visibility of ground reflections.

How it Works
When editing an existing material select Metal, Glass (Solid), Liquid, Dielectric, Gem, Metallic Paint, Translucent, Translucent (Advanced) or Toon from the Material Type drop-down. Note: When opening KeyShot 6 scenes in KeyShot 7 the material types listed above will automatically be updated to include the listed enhancements.

Texture Mapping

Texture Mapping has been completely refreshed for KeyShot 7. Updates include an improved interactive mapping tool, and the ability to specify Center On: Model or Part. The new Planar mapping type is highly versatile - replacing Normal Projection, Planar X, Y and Z. This now gives you the ability to control Depth for Planar projections. Cylindrical Mapping has also been vastly improved. 

Note: Old KeyShot scenes will still use the legacy texture mapping for existing textures and labels when opened in KeyShot 7. Click the Upgrade to New Node button to convert the legacy texture mapping to the new mapping technique. Some shifts may occur when doing so.

New Texture Types
KeyShot 7 features three new Image Texture types and three new 2D Texture procedural types. Learn more about the new Texture Types.

  • Tri-Planar - project textures to each plan independent of the other

  • Tiled UV - apply and filter multiple UV texture tiles

  • Video Map - apply a video as an animation

  • Brushed - new procedural with more brushed appearance options

  • Mesh - consolidated and improved mesh texture capabilities

  • Weave - new procedural for fiber and cloth textures

Other Texture Improvements

Other improvements to Textures include:

  • Unit-aware size parameters across all Texture Types

  • Unit-aware Radius setting for Occlusion and Curvature Procedural Texture

  • Color Map support for Area Light Diffuse material 

Environment List

The Environment tab of the Project window now includes the ability to save Environments and their settings to a list in order to quickly access and toggle. Learn more in the manual about the Environment List.

How it Works
When a new scene is opened the Environment list is populated with the startup environment at default settings. All changes made to the settings will be recorded and saved with that environment. To create a new environment based on the current settings click the Add Environment icon at the top left of the dialog. Alternatively, you can populate the list with environments by dragging-and-dropping one or more from the Environment Library.

Copy/Paste Position

You can now copy and paste the position of one object to the position of another object. You will find Copy Position and Paste Position options when you right-click a model in the Scene tab.

Multi-Material pro.png

Any material can be turned into a Multi-Material to facilitate non-destructive material swapping, variations and color studies. The Multi-Material allows you to cycle through a variety of materials within a single “container” material. Learn more in the manual on the Multi-Material page.

How it Works
When editing a material click on the three-arrow Multi-Material icon above the Material Type dropdown to convert a single material to a Multi-Material. Once you have done so a list will be displayed that can be populated by drag and drop or by using the buttons along the left side of the list. Simply select a sub-material in the Multi-Material list to make it active in the Real-time View.

Video Map Textures pro.png

Image sequences can now be set as Textures or Labels to animate device displays and much more. The supported formats at the moment include avi, mp4, mpeg, flv, webm, dv, f4v, mov, mlv, m4v, hevc, ogg, and ogv. Note: Some formats may have variants encoding which are not supported (for example, avi may include encodings which may not be directly supported.) Learn more in the manual on Video Map Textures.

How it Works
From Project > Materials > Textures select “Video Map” from the Texture dropdown menu or Add Label (Video) from the Labels tab. Select an image sequence in the file browser or a video file to extract the frames. This will create a node in the Animation Timeline in which you can position and adjust similar to other Animation types.

Panoramic Camera pro.png

The Panoramic Lens Setting for Cameras allows you to render a Spherical or Cube Map image in real-time or rendered output. This feature can be used to render out your own spherical EXR images to use as Environments to light KeyShot scenes or to load in your VR headset image viewer. Learn more in the manual about the Panoramic Lens Setting.

How it Works
In the Camera tab, under Lens Settings, select Panoramic. Select your desired format of Spherical or Cube Map from the Mode drop-down menu. The Real-time View will display a Panoramic Preview message at the top to indicate you are Panoramic mode. This means that you can mouse around the Real-time View and the image will not re-render. Click the Reset View button at the bottom of the screen to do just that. Click the Preview Map button in the Lens Settings to see a flat preview of your Panoramic image. When using the Spherical Mode the Resolution in the Image tab will be locked to a 2:1 ratio. Cube Map Mode will be locked to an 8:1 resolution. Try increasing the pixel resolution if the image does not appear clear.

Real-time VR Rendering pro.png

Real-time VR rendering and output is available with the support for Stereo Perspective Cameras, Stereo Spherical Maps, and Stereo Cube Maps. These can viewed within KeyShot in real-time or output as still images and animations. Spherical and Cube Maps offer a 360-degree stereo viewing experience while Stereo Perspective shows a stereoscopic image of the viewport. Read more in the manual about Stereo VR Support.

How it Works
Support has been added for real-time Oculus Rift and HTC Vive Head Mounted Display (HMD) viewing. From the Camera menu click Enable VR to add a new VR camera. Or do so manually from the Camera tab by enabling the Stereo accordion for your Perspective or Panoramic Camera. Click the Head-Mounted Display button to select Oculus Rift or OpenVR for HTC Vive to open the HMD viewing window.

Configurator 

KeyShot 7 introduces the KeyShot Configurator - a tool for presenting Model and Material variations in real-time for design reviews and interactive point-of-sale displays.

How it Works
To access the Configurator Wizard click Window > Configurator Wizard or select the Configurator Wizard icon configurator.jpg on the Ribbon. Here you can define Parent Models, Components, and Material Variations. Enter Presentation Mode and use the toolbar to control the Model and Material being displayed. Read more about the KeyShot Configurator.

Studios 

KeyShot Studios is the new way to combine and save scene variations in one file for quick creation and presentation. Studios may contain any combination of Camera, Environment, Models Sets or Multi-Materials. Learn more in the manual about KeyShot Studios.

How it Works
View the Studios window from the main menu under Window, Studios... The Studios window is a dockable window and may also be accessed from the Ribbon at the top of the KeyShot interface by selecting the Studios icon .

Within the dialog there are four dropdown menus that display the currently active Camera, Environment, Model Sets or Multi-Materials. Click the Add Studio icon in the top left corner to add a new Studio with the active elements added to that Studio.

Inline with the Studio name are icons that indicate what elements are included in that Studio. By default the active Camera and Environment are included when a new Studio is created. With a Studio active, uncheck any checkbox to exclude that element from the Studio. To modify a Studio simply select a different Camera, Environment, Model Set or Multi-Material from the dropdown menus. Multiple Model Sets can be added to a Studio by checking the corresponding boxes within the Model Sets dropdown menu.

To copy a Studio, select an existing Studio in the Studio window and select Add Studio. This will copy the elements into a new Studio where you can change the selection as needed.

Re-Tessellate 

Models that have been imported with NURBS included can be re-tessellated directly in the scene without having to re-import the model. This tool allows you to fine tune tessellation quality of entire models or individual parts in a scene to optimize appearance and file size. Learn more in the manual about Re-Tessellate.

How it Works
In order for Re-Tessellate to be available for a model or its parts the Include NURBS Data checkbox must have been enabled upon import from the Geometry section of the Import dialog.

Access the Re-Tesselate function by right-clicking on a model, part, or multi-selection of parts in the Project window, Scene Tree or Real-time View and selecting Re-Tessellate. This will open the Tessellation Settings dialog where you can adjust the overall Tessellation Quality or drill down to access finer adjustments including Angle Tolerance, Distance Tolerance, and Maximum Edge Length. Click the Tessellate button to show a preview in the Tessellation Settings dialog, which can be displayed as a Wireframe or Glossy representation. Click Apply to commit the changes to the scene. Cancel will revert all changes and exit the dialog.

Move Active Camera 

The Active Camera in the Geometry View can now be manipulated with a move tool. This features makes positioning cameras in interiors especially easy.

How it Works
Hit the O-key or select Window, Geometry View... to activate. Set Camera Type in Geometry View to Perspective or Orthographic. Right-click and select a Move Active Camera option. As the camera is moved in the Geometry View, the Real-time View and camera properties in the Project window update as well. Note: If a camera is locked, you will need to select Unlock Camera to unlock the camera prior to moving it.

Move Active Camera Position
This changes the actual position of the camera. With the camera unlocked, right-click in the Geometry View and select Move Active Camera Position. Use the Move Tool to change the position.

Move Active Camera Target
This changes the ‘look at’ point of the camera. With the camera unlocked, right-click in the Geometry View and select Move Active Camera Target. The Move Tool will appear on the ‘look at’ point. Use the Move Tool to change the position.

Right-click and select Save Camera to update the current camera position or target, or select Add Camera to create a new camera. The new camera will appear in the Project window, Camera tab where the camera changes may be saved or added as well.

Integrated HDRI Editor 

The KeyShot HDRI Editor is now fully integrated into the Environment tab of the Project window. All Pins and Adjustments are embedded in the KeyShot file so there is no need to save an individual .HDZ for each custom Environment you create. This provides a huge convenience and asset management benefit while greatly reducing the amount of data necessary to store locally and in .KSP files. Learn more in the manual about the HDRI Editor.

The HDRI Editor is also much more flexible with new features including:

  • Export of HDR/EXR

  • Gradient Background

  • Draggable interactive Sun & Sky

  • Sun & Sky Ground Color

  • Sun Size parameter

  • Rectangular Pin Rounded Corners

  • Gradient Pins

  • Image Pin Color Adjustments

  • Extract pins from previous version HDZ files

How it Works
The HDRI Editor can be accessed from it’s sub-tab in Project > Environment. All pins and adjustments will be added to the Environment currently selected in the Environment list.

Deformation Animation Support 

Deformation animations may be imported as Alembic cache files, played back in real-time, and rendered.  Learn more in the manual about Deformation Animations.

How it Works
Start by importing an .ABC file. On the KeyShot Import dialogue, in the Animation section, select the Deformable Meshes option and select Import. The file will import and appear as an animation on the Animation Timeline where it may be positioned and adjusted similar to other Animation Types.

All New Network Rendering 

KeyShot Network Rendering has been rewritten from the ground up. To see the complete list of new features, along with how to install and use the new features please see the KeyShot 7 Network Rendering Manual.


On this page: