Real-time View

Real-time View

The KeyShot Real-time View is the main viewport in the KeyShot user interface. All real-time rendering of your 3D model will occur here. You can navigate your scene using the camera controls, multi-select objects and right-click directly on your model or in the area around it to view more options.

Heads Up Display

For information concerning the Real-time View you can turn on the Heads-Up Display via the Main Menu under View > Heads-Up Display.

The Heads-Up Display will be located in the top left corner of the Real-time View. It shows frames per second, time and number of samples the Real-time View has been rendering, the amount of triangles and NURBS in the scene, the Real-time View resolution, and the current focal length of the camera.

Coordinate Legend

To help orientate in the Real-time View you can turn on the Coordinate Legend. This will show the X,Y and Z axis of the current view. Turn on the Coordinate Legend via the Main Menu under View > Coordinate Legend.

In-view indicators

Under some circumstances in-view indicators will be displayed in the top right corner of the Real-time View.

The Render Nurbs indicator will be displayed when Render Nurbs is active and the Ribbon is hidden.

The Performance Mode indicator will be displayed when Performance mode is active and the Ribbon is hidden.

The Lock indicator will be displayed when the camera is locked and the Ribbon is hidden.

The Generate Environment indicator (pro) will be displayed when you have made changes in the HDRI editor and these are not yet generated in the full resolution. You can click the indicator to generate the environment in full resolution. Learn more about the HDRI editor.

The Execute Geometry Nodes indicator (pro) will be displayed when the scene contains geometry with geometry nodes (displacement/bubbles/flakes) which have not been executed. Click the indicator to execute all geometry nodes in the scene. Learn more about Geometry Nodes.

Docking windows

Windows with resources and editing options (see which here) can be docked inside the Real-time View. You can dock windows on the sides and in the bottom of the view - and in multiple columns/rows if desired. to dock a window drag it by the title-bar towards the middle of the edge you want to dock it to, when a grey docking area is expanded, simply drop the window there. To undock drag the window, by the title bar, away from the dock area.

The Real-time View will respect the resolution/aspect ratio set in the Image tab and docked windows can only be resized accordingly.



On this page