Feature Highlights

KeyShot 9 introduces the following top new features and improvements:

Feature Categories

Top Features

Other New Features

Top Improvements


Import & Integration

Streamlined Import

The Import dialog and workflow has been updated in KeyShot 9 to speed up your Import efficiency. Updates include the ability to import a KeyShot Package File (.ksp) directly into an open scene with the options to exclude components of a scene i.e. Models, Cameras, Environments, Image Styles, and Studios. In addition, users of KeyShot Pro now have the ability to import directly into a new or existing Model Set.

The interface of the Import dialog has been updated to use less vertical space and Import terminology has been updated to more clearly communicate function.

How it Works
You will be presented with the updated Import dialog upon import of any supported filetype in KeyShot 9 with the relevant options and parameters shown for each respective filetype.

Quick Import

The Enable quick import option allows you to further streamline the import process by selecting it along with default import settings for your favorite filetypes which will bypass the import dialog altogether. Learn more about model import.

How it Works
When importing a new filetype you will be presented with the KeyShot Import dialog. To the bottom-left of this dialog you will see the Enable Quick import checkbox. By selecting this, KeyShot will save the settings to the Import Settings under Edit, Preferences and use those when importing the same filetype.

To display the KeyShot Import dialog again on Import use File, Import Dialog or hold Alt when dropping a file into the Real-time View.

Resolve Missing Resources

In KeyShot 9 you can now more easily relink missing textures, backplates, etc. upon opening a scene.

How it Works
When opening a .bip or .ksp file and there are missing resources you will be presented with the Resolve Missing Resources dialog where you can browse to a path to relink them.

Browzwear VStitcher Plugin

This new plugin allows you to send your garments from VStitcher straight into KeyShot 9 with all textures included. Learn more and download the VStitcher plugin.

How it Works
Once the plugin has been installed you will see an item for KeyShot in the VStitcher plugins menu. Once your avatar has been dressed, select Render to KeyShot to launch KeyShot 9 and load your garments. Note: There is currently no Live-Linking functionality so each time you Render to KeyShot a new session will be launched.

Substance Painter Material Import

KeyShot 9 adds the capability to automatically generate materials from texture sets exported from Substance Painter.

How it Works
Install the Substance Painter Plugin to add a Generic Texture Set export configuration in Substance Painter. Export your texture set to you preferred location using this configuration. In KeyShot, select Tools, Material Importer, Substance Painter Set (*.sp) from the Ribbon. From the location you exported the Substance Painter texture set, select the folder ending with .sp to load the textures into the material list dialogue box. From the dialogue, you can drag and drop into your scene to apply. Learn more about the Material Import Tool and Generic Material Type.

X-Rite AxF 1.6

This X-Rite AxF update adds support for scattering media/cloudy-plastic like materials and loading AxF data directly from memory. There has also been a fix to black spots appearing at grazing angles with bump textures. On import, the AxF material is converted into a KeyShot material that uses the Measured material type. The properties for the AxF material will be mirrored in the Measured material, Properties tab. Learn more about the Material Import Tool and Measured Material Type.

How it Works
In KeyShot 9, on the Ribbon, select Tools, Material Importer, and choose X-Rite AxF (*.axf). Browse to a .axf file, and select a folder in the KeyShot Library to save your new Measured material. To create from scratch, go to the material type dropdown and select Measured to load an AxF file. 

Vizoo U3M Support

KeyShot 9 supports the import of Unified 3D Material (u3m) files through the new Material Importer tool. On import, the U3M material is converted into a KeyShot material that uses the Generic material type. The properties for the u3m material will be mirrored in the Generic material Properties tab. Learn more about the Material Import Tool and Generic Material Type.

How it Works
In KeyShot 9, on the Ribbon, select Tools, Material Importer, and choose Unified 3D Material (*.u3m) then browse to a .u3m file alongside its "textures" folder. You will then be prompted to select a folder in the Library to specify where the material will be saved.

Workflow & Setup

GPU Mode

KeyShot 9 introduces the ability to harness the full GPU-accelerated ray tracing power of NVIDIA RTX with OptiX. Available for both real-time rendering and local render output, KeyShot’s GPU Mode allows GPU resources to be accessed with one-click to take advantage of multi-GPU performance scaling and the dedicated ray tracing acceleration hardware in NVIDIA RTX-capable GPUs. You may toggle between GPU and CPU as needed. GPU ray tracing in KeyShot 9 supports the NVIDIA Maxwell microarchitecture found in the Quadro M6000 or GTX 980 and above. Read more about GPU Mode.

How it Works
When KeyShot detects a compatible GPU, it will enable the GPU button on the Ribbon. When enabled, the image in the Real-time View and the rendered output will be rendered on the GPU instead of CPU. When GPU is enabled the CPU Usage core selection drop-down menu on the Ribbon will change to a GPU Usage selection drop-down where you can control which GPU(s) are being used.

GPU mode in Network Rendering

With KeyShot 9.1 and KeyShot 9.1 Network Rendering you can also send GPU jobs to Network Rendering - even from a Mac or a PC without a GPU that meets requirements for running in GPU mode locally. 

How it Works
The Network Rendering Manager can have both CPU and GPU Workers connected. With the Network Configurator each Worker can be set up to work on CPU/GPU/both types of jobs. You don't need a specific license to be able to utilise GPU Workers - one GPU simply takes up 16 cores out of the total available cores on the license. Once you have configured your workers, you are ready to submit GPU jobs from KeyShot - simply select the GPU mode in the Render output settings and press Send to Network. Visit the Render Output page or the Network Rendering manual to learn more.

3D Model Library

Adding context and detail to your scene is easier than ever with Models now available on the Cloud Library to download straight into your KeyShot Library and add to your scene. Learn more about working with Library Models.

How it Works

In the KeyShot 9 Library window you will now see a new Models tab. You can add your own models/scenes by clicking the Add model to Library from scene button next to the search bar. In this dialog, you can define which components in your scene are included to suit your desired workflow.

To explore Models on KeyShot Cloud, launch the KeyShot Cloud from the Toolbar button (at the far left). You will see a Models tab that contains curated and optimized, high-quality models with materials assigned that you can download straight to your KeyShot 9 Model Library. Simply drag-and-drop a model from the Model tab to the Real-time View to add and position the model in your scene. To center and snap a model to the ground, double-click (or right-click) the model in the Library and select Add to scene.

Tools Menu

Geometry, Material, and Camera tools are now grouped in one easily accessible place. Learn more about the Tools menu.

How it Works
In KeyShot 9, click on the Tools icon located on the Ribbon to see all tools available. Tools are grouped into Geometry tools (Move Tool, Edit Normals, Re-Tessellate, Close Mesh, Split Object Surfaces, and Split Separate Objects), Material tools (Material Templates, Substance Painter Importer), and Camera tools (Set Camera Target, Match Perspective).

Unwrap UV tool

Good UV's are essential when you need to position labels on complex surfaces, use materials such as RealCloth or control the seams and direction of a texture on your object. In 9.1 the Unwrap UV tool enables you to generate UV coordinates for your objects.

How it works
In KeyShot 9.1 click the Tools menu in the Ribbon, there you will find the new  Unwrap UV tool. Select the part you want to unwrap and use the options to set seams select charts and add direction guides, to generate a set of UV coordinates that meets your needs. Learn more about the Unwrap UV tool.

Improved HDRI Editor Pin Interaction 

Working with pins in the HDRI Editor has been improved with the addition of new hotkey support to streamline your workflow.

How it Works

  • 'Isolate' has been added to the right-click context menu and also by using Alt + LMB click.
  • Holding Shift while dragging a pin in the HDRI Editor canvas restricts the pin to vertical and horizontal movements.
  • Holding Alt by dragging a pin in the HDRI Editor canvas creates a duplicate of the pin.
  • Ability to copy/paste a selection of pins from one environment to another via hotkeys.

Configurator Sup-Components 

The Configurator now supports Sub-Component Groups to define a 3rd level of dependency between Parent and Components.

How it Works
On the Component Group page of the Configurator Wizard you will see blue links within component groups which allow you to add a sub-component group when clicked.

Configurator Thumbnails 

You can now use custom image thumbnails for model and material variations in the Configurator.

How it Works
On the Summary page you will see the respective thumbnail for the selected item in the summary list. Click the Replace Thumbnail button to browse to a custom image or render a new thumbnail.

Custom Motion Ease 

Custom Motion Ease brings users more control over part and camera animations. Custom motion easing may be applied to each animation on the Animation Timeline using custom curve control in the Time Settings of the Animation Properties. Keys may be added quickly along the curve with interpolation and tangency control for each key with all adjustments seen in real-time. Learn more about Custom Motion Ease.

How it Works
In KeyShot 9, select an animation on the Animation Timeline. You will see a new option in animation Properties, Time Settings, in the Motion Ease dropdown menu for Custom. When this option is selected you will be presented with a new curve graph for granular control over the selected animation. New keys may be added along the curve by right-clicking in the curve graph and selecting Add Key. Curves may also be copied and pasted from one animation to another.

Curve Fade Animation 

Curve Fade Animation brings users more control over material animations. Applied as a Animation node in the KeyShot Material Graph, a Curve Fade animation may be applied to a material color, bump, opacity or other property. Like Custom Motion Easing, a custom curve control graph allows keys to be quickly added along the curve and adjusted in real-time to create animated material effects. Learn more about Curve Fade.

How it Works
The Number Fade material animation is now called the Curve Fade material animation. In the KeyShot Material Graph, a Curve Fade node may be added by right-clicking in the Material Graph and selecting Animation, Curve Fade. Double-clicking on the node will display the Curve Fade Properties to the right. Under Animation, the curve control graph appears. New keys may be added along the curve by right-clicking in the curve graph and selecting Add Key. Curves may also be copied and pasted from one Curve Fade material animation to another.


Materials & Textures

Contour Procedural Texture

This new procedural texture type is very similar to the Toon material that already exists in KeyShot. With Contour as a texture, you now have more control and flexibility while creating custom materials. You can use it to add an illustration-like effect on top of real-world materials such as metal or plastic. 

How it Works
In the Texture dropdown menu you will now find a new item for 'Contour'. It can be used like any other procedural texture to drive texture channels such as color, roughness, and opacity.

Generic (BRDF) Material

This new Material Type is based on the Disney BRDF shader that provides a huge amount of flexibility with a number of parameters that can be adjusted to achieve a wide variety of material finishes. Learn more about the Generic Material Type.

How it Works
You will find this new material type in the Advanced category of the Material Type dropdown menu found in the Project Material tab.

RealClothTM Material

RealClothTM is a patent-pending technology from Luxion driving a powerful, new material type that allows the creation and visualization of realistic woven materials. The material type provides intricate control of the weave pattern (Pro) and the ability to easily add flyaway fibers. New RealCloth materials have been added to the Library as well. Learn more about RealCloth.

How it Works
In KeyShot 9 there is a new material type for RealCloth that you can find in the material type dropdown menu in Project > Material.

Fuzz Geometry Shader 

Fuzz is a new geometry shader accessible through the KeyShot Material Graph (Pro) that allows you to add randomized, hair-like growth from the surface of any material. You can control several parameters of Fuzz such as Length, Randomness, and Density to create a range of appearances. In addition, you can modify the appearance through the built-in material properties or input a different material type to the surface of the Fuzz node for even more control. Learn more about Fuzz.

How it Works
In the KeyShot Material Graph, a Fuzz node may be added by right-clicking in the Material Graph and selecting Geometry, Fuzz. Double-clicking on the node will display the Fuzz Properties to the right. Properties for Length and Length Variation will affect how long the fuzz is, while Radomness affects the straightness. Fuzz can also be controlled using Density, Length and Direction textures from the Textures tab. Appearance properties (Color, Specular, etc) are located below the main Fuzz properties.


Image & Output

Denoise

Denoise is a one-click Image Style option that works in both CPU and GPU mode to eliminate noise in the Real-Time View and render output. This deep learning denoiser reduces the time it takes to resolve a rendered image by interpolating and refining the image to achieve smooth results in less time. Learn more about Denoise in Image Styles.

How it Works

The Denoise function is easily enabled by clicking Denoise on the Ribbon. This will enable Denoise for the currently active Image Style and is reflected in the Image tab of the Project window. In both the Basic and Photographic Image Styles you will find a new Denoise option that contains a slider for Denoise Blend to control how much of the denoised image is shown. When this is set to 0 you will see no Denoise effect in the real-time view or render output. At a value of 1, you will see a completely denoised image. Any values in between 0 and 1 will blend the original and denoised images which can be useful if the Denoise effect starts to reduce the clarity of fine detail and textures in your image.

When the Ribbon is not shown or in Presentation Mode you will notice a Denoise button in the Real-time View for easy access.

There is an item in Preferences, General, Denoise for Refresh time to set the time increment in seconds in which the image is denoised. As the number of samples increases the denoise result will improve.

The best Denoise results occur when using Product Mode rendering. It's also important to keep in mind that multi-frame renderings such as Animation, Configurator, and KeyShotXR output will likely create a very high RAM load.

Photographic Image Style Response Curve

This new feature in the Photographic Image Style allows you to use a linear, low contrast or high contrast Response Curve.

How it Works
In KeyShot 9, go to Project > Image > Photographic > Tone Mapping to find the Response Curve selection. The Linear response curve is similar to the Basic Image Style. The Low Contrast Response Curve is suitable for scenes with a high dynamic range between light and shadow i.e. interiors with Sun & Sky. The High Contrast Response Curve is suitable for scenes with low to moderate range between light and shadow i.e. product shots with diffuse lighting.

Improved STL Color Texture Export 

Users of KeyShot Pro can now Export STL files for 3D printing with improved accuracy of vertex colors from both texture maps and procedural textures.

How it Works
In KeyShot 9, select File, Export to STL..., select Save, and in the KeyShot Export dialog that appears, select Export as vertex color from the Texture Mode dropdown menu. Note: Depending on the tessellation of the model it may require subdivision for color textures to be displayed accurately.

Web Configurator (KeyShotWeb)

KeyShot 9 now offers the ability to output fully-rendered, static product viewing and configuration in a web browser. Just like Presentation Mode in KeyShot, you can select from Model, Material, and Studio options to configure your product. Unlike Presentation Mode, the Web Configurator displays fully-rendered images to give you full control and endless capabilities. The Web Configurator is output as an HTML file with associated images and files included so that you can zip and share locally or host on your website for anyone around the world to access. Learn more about KeyShotWeb.

How it Works
Once a configuration has been set up through the Configurator Wizard, navigate to the Render dialog, select the Configurator tab in the Output section and select the Web Configurator option. The Web Configurator uses the layout settings from the Configurator Wizard and supports both vertical and horizontal layout styles.

Streamlined Wizard (Network Rendering)

The Network Rendering Setup Wizard and the Network Rendering Configuration dialog have been merged to make for a more streamlined installation and setup experience.

How it Works
When KeyShot 9 Network Rendering is installed you will now be directly presented with the Network Configuration dialog to lead you through the setup process.

Run Parallel Jobs (Network Rendering)

KeyShot 9 Network Rendering now allows you to process multiple jobs simultaneously.

How it Works
In the KeyShot 9 Network Configurator > Manager Settings > Job Settings you can now set the number of parallel jobs to be distributed amongst your workers to render simultaneously.

Name Templates

With Name Templates (introduced in KeyShot 9.1) you now have precise control over what is generated as the Render name. This is based on what is active in your scene, with options ranging from the Scene Name, Active Camera, Current Date, and more.

How it works
In the Output section of the Render Dialog you can select one of the Name Template presets, or set up your own preset based on variables that extract information from the scene and that way generate a descriptive name for your rendering. Learn more about Name Templates