User Interface Updates

9.1

The following user interface improvements have been made in KeyShot 9.1.

Theme

  • Selection color in Dark Theme has been changed for better readability.
  • Link color in Dark theme has been changed for better readability.

Menu

  • New item in the Image menu for toggling Denoise.

Project Panel

  • Default order in project panel has been changed to match the most common workflow.

Render Dialog

  • Information about CPU/GPU Mode has been added to the Render Queue details.
  • Updated the text and tool-tip for the Update functionality for Web Configurator in the Configurator tab.

Configurator

  • Improved margins around thumbnails in presentation mode

Materials

  • u3m materials now have ‘Use DPI for Size’ enabled by default
  • A warning has been added when the scene exceeds the geometry shader limit

Tools

  • Move tool and move options will now correctly respect locked state

Import /open scene

  • Added a tessellation quality slider in DWG import
  • Files that are saved in performance mode will now open in performance mode again.

9.0

The following user interface improvements have been made in KeyShot 9.

Menu

  • New items in the Render menu:
    • Option to Copy screenshot to clipboard. This also has the option of having a hotkey assigned.
    • Toggle GPU mode: This item is present, if you have a GPU that meets requirements. 
    • GPU Usage: Enables you to limit the GPU usage GPU mode.
  • New import option in the File menu. The regular Import option will now import with the user's saved import settings (if enabled). To facilitate exceptions to the saved settings an Import Dialog option has been added. This will always show the Import dialog
  • New item in the Help menu for Open (Recovery Mode)... If you experience problems when opening a scene you can now open it in "recovery mode". This means that the scene will be opened in Performance mode and geometry nodes, including flyaway fibers on RealCloth, will not be executed.

Project panel

  • Full size Model Set thumbnails are now shown when hovering Model Sets in sidebar.
  • Option to Duplicate added to the Model Set context menu.
  • Option to Link Materials added to the Pattern tool
  • New hotkey (Ctrl+w/Cmd+w) for duplicating selected parts (also works with selection in the Real-time View)
  • Triangle count in Scene > Properties sub-tab for group, part, and multi-selection.
  • Animation now included in the Camera list right-click context menu.
  • The Depth of Field, Set Focal Point button has been replaced with a Cross-hair icon next to the Focus Distance input field.

Studios

  • Option to Render High Res thumbnails added to the Studio panel settings

Ribbon

  • GPU, toggles the new GPU mode.
  • Denoise, toggles the new denoise functionality, which is a part of Image styles.
  • Tools, drop-down that gives access to a collection of tools. Including Move tool and Material Templates, which could previously be found in the ribbon itself.

Consistency

  • Renaming has been streamlined, so it consistently can be triggered by a click on a selected item.

Tools

Selected functionality has been migrated to the Tools drop-down on the ribbon to provide easier access and an improved experience. The Tools menu is split into three categories: Geometry Tools, Material Tools, and Camera Tools. Also some of the tools have had an update of the UI.

Geometry Tools

  • Move Tool - The widget has been moved out of the rendered part of the Real-time View, so it from now on can be placed freely inside the Real-time View.
  • Close Mesh (PRO) - the tool have been moved from the geometry view, and now has the preview as an integrated part of the tool.
  • Edit Normals (PRO) - the tool have been moved from the geometry view, and now has the preview as an integrated part of the tool.
  • Split Separate Objects (PRO) - the tool have been moved from the geometry view, and now has the preview as an integrated part of the tool.
  • Split Separate Surfaces (PRO) -the tool have been moved from the geometry view, and now has the preview as an integrated part of the tool.
  • Re-tessellate (PRO) - the UI has been updated to match the other tools

Material Tools

  • Material Templates
  • Material Importer - New tool, which allows you to import .axf and .u3m files, as well as import and generate materials from Substance Painter Texture sets.

Camera Tools

  • Match Perspective
  • Set Camera Target - widget has been expanded. It now offers the option to select type of target - Point on surface/ Center of Part/ Center of Mode

Environments

  • Added modifier keys for better handling of pins in the HDRI editor
  • Shift+drag will restrict drag movement to horizontal/vertical axes
  • Alt+click will isolate the Pin
  • Alt+drag will duplicate pins

Image styles

  • Choice of response curve has been added to the Photographic style
  • Denoise has been added

Import

  • Import dialog has been updated
  • Option to set up default import settings added (for each import format), which enables the user to skip the Import dialog entirely on regular import.
  • Modifier key added to trigger import dialog - Hold Alt when importing via drag and drop
  • Resolve missing resources function added on import/open

Animation (PRO)

  • New animation node Curve Fade for custom fading between values. Replaces the Number fade node.
  • New icon on Color Fade node in the material graph
  • New option to use custom Easing curves on animations.
  • Icons for Imported Animation and Linked Imported Animation added
  • Option to sort items in the timeline.

Configurator (PRO)

The Configurator has been updated so it can handle Sub-Components, which is reflected in the Component Group step of the Configurator wizard as well as in the Presentation mode layout.

  • Default thumbnail for “None” options in Component Groups added.
  • Materials, Material Ways etc. can now be re-ordered in the Material Variations list
  • Default thumbnails for Material Ways will now show the first 3 materials in the Material Set.
  • The appearance of the Material variations list and the Summary in the Configurator has been updated for easier overview
  • The Material Variation step of the Configurator wizard now reflects Material Sets and Material Ways.
  • Option to set font size added to the layout step the Configurator wizard
  • New hotkey (Q) for launching the Configurator wizard.