Substance Painter

KeyShot for Substance Painter Plugin

Version: 1.1

These installation notes are specific to the latest version of the KeyShot for Substance Painter plugin unless otherwise mentioned. For questions about other versions, please contact support@luxion.com.

 

Specifications

The Substance Painter export settings will install an export configuration for Export Textures in Substance Painter called KeyShot 9+.

When using this export configuration, the result of the export can be imported into KeyShot with the Material Importer. This creates a Generic Material for each Substance Painter texture set. The requirements are:

  • Substance Painter
  • KeyShot 9 (Try | Buy)
  • Windows (64-bit) or macOS (10.10 and above)

Supported Features

The KeyShot 9+ Substance Painter export configuration plugin supports these features:

  • File structure which can be used with the KeyShot Material Importer for creating Generic Materials

Installation

Windows

  1. After downloading, double-click the .exe file
  2. Follow the prompts inside the installation wizard and click Close.

Mac

  1. After downloading, double-click the .dmg file
  2. Drag the "KeyShot 9+.spexp"-file to the "Substance Painter"-folder

Once installed a KeyShot 9+ Config option will appear in the Export Textures dialog in Substance Painter.

How To Use The KeyShot 9+ export configuration

In Substance Painter:

  1. Create one or more texture sets
  2. In the File menu select "Export Textures..."
  3. Chose one of the following texture file types: jpeg, tiff, bmp, png, gif, hdr, exr, tga
  4. Write the path to the location where you want the export to be placed
  5. In the Config-dropdown* select KeyShot 9+
  6. Push the Export button

This creates a folder with a .sp extension located at the desired export location. In the .sp folder there is a folder for each texture set, these folders have a .ts extension. In each .ts folder the required texture maps are placed.

In KeyShot:

  1. In the ribbon select Tools → Material Importer → Substance Painter set (*.sp)
  2. Select the exported .sp folder
  3. A dialog will appear with a list of generic materials, one for each Substance Painter texture set
  4. The generic materials can be dragged onto parts in the scene

Note: A mesh can also be transferred from Substance Painter to KeyShot. In the File menu in Substance Painter select "Export Mesh..". Chose to export as either .dae or .obj. Import the exported mesh in KeyShot using the Import Dialog.


*Output Template in Substance Painter 2020 or later